假定有一个无限长的数轴,数轴上每个坐标上的数都是 $\rm{0}$。
现在,我们首先进行 $n$ 次操作,每次操作将某一位置 $x$ 上的数加上 $c$。
接下来,进行 $m$ 次询问,每个询问包含两个整数 $l$ 和 $r$ ,你需要求出在区间 $\left[ {l,r} \right]$ 所有数的和。
输入格式
第一行包含两个整数 $n$ 和 $m$。
接下来 $n$ 行,每行包含两个整数 $x$ 和 $c$。
再接下来的 $m$ 行,每行包含两个整数 $l$ 和 $r$。
输出格式
共 $m$ 行,每行输出一个询问中所求的区间内数字和。
数据范围
$- {10^9} \le x \le {10^9}$
$\rm{1} \le n,m \le {10^5}$
$- {10^9} \le l \le r \le {10^9}$
$- 10000 \le c \le 10000$
输入样例
3 3
1 2
3 6
7 5
1 3
4 6
7 8
输出样例
8
0
5
题解
(离散化、前缀和)
对于数据量比较小的数组,可直接使用前缀和操作即可,但如果数据量很大,如本题:$- {10^9} \le x \le {10^9}$,如果依然使用前缀和就可能超出时间限制!
根据题意,虽然数据的范围很大(${10^9}$),但需要我们处理的坐标最多也就是$\rm{3} \times {10^5}$,即 $n + 2m$ ($\rm{1} \le n,m \le {10^5}$),所以将其离散化可以节省很多不必要的操作,因为没有处理的数组坐标对应的值就是 $\rm{0}$,我们求前缀和的时候,就将这些为 $\rm{0}$ 的区域忽略掉。
离散化即是把无限空间中有限的个体映射到有限的空间中去,此题我们把需要处理的数组下标映射到一个新的容器 alls
中去,定义 find()
函数来返回离散化容器 alls
中对应坐标的位置,最后,用之前的前缀和思想即可在较短时间实现题目要求。
C++ 代码
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
typedef pair<int, int> PII;
const int N = 300010;
int n, m;
int a[N], s[N];
vector<int> alls;//需要操作的坐标
vector<PII> add, query;
//二分查找坐标x在离散化坐标容器vector alls中的位置
int find(int x)
{
int l = 0, r = alls.size() - 1;
while(l < r)
{
int mid = (l + r) >> 1;
if(alls[mid] >= x)
r = mid;
else
l = mid + 1;
}
return r + 1;
}
int main()
{
cin >> n >> m;
for (int i = 0; i < n; i++)
{
int x, c;
cin >> x >> c;
add.push_back({x, c});
alls.push_back(x); //存储将要操作的坐标
}
for (int i = 0; i < m; i++)
{
int l, r;
cin >> l >> r;
query.push_back({l, r});
alls.push_back(l); //存储将要操作的区间坐标
alls.push_back(r);
}
//去重(unique()函数必须排序后使用)
sort(alls.begin(), alls.end());
alls.erase(unique(alls.begin(), alls.end()), alls.end()); //unique()函数去除连续重复值,将其余值接在后面,返回去重后的末尾迭代器,该迭代器对应的即是其余值的起始位置。
//处理插入
for(auto item : add)
{
int x = find(item.first);
a[x] += item.second;
}
//预处理前缀和
for (int i = 1; i <= alls.size(); i++)
s[i] = s[i - 1] + a[i];
//处理询问
for(auto item : query)
{
int l = find(item.first), r = find(item.second);
cout << s[r] - s[l - 1] << endl;
}
return 0;
}
unique()函数实现方法
由于 Java 和 Python 中无 unique()
函数,对此给出 unique()
函数的具体实现(C++):
//双指针算法
vector<int>::iterator unique(vector<int> &a)
{
int j = 0;
for (int i = 0; i <= a.size(); i++)
{
if(!i || a[i] != a[i - 1])
a[j++] = a[i];
}
return a.begin() + j;
}
版权属于:字节星球/肥柴之家 (转载请联系作者授权)
原文链接:https://www.bytecho.net/archives/1789.html
本作品采用知识共享署名-非商业性使用-相同方式共享 4.0 国际许可协议进行许可。